| Home | Forums |

REQUIREMENTS:
Quake is required to play Feral. Download it here if you don't already have it.

DOWNLOAD:
Feral alpha 0.11
1/16/09
This build comes with Darkplaces SDL 20080819beta2

Contact: daemon @ daemonforge.org